WordPress <= 1.3.0 - Eval Injection

wordpress

Software
WordPress
Versions
1.3
Disclosure date
2005-06-08
CVE
CVE-2005-1921
References
Credits
Classification
Arbitrary Code Execution
OWASP Top 10

Are your websites subject to this vulnerability?

Details

Because of this vulnerability in PEAR XML_RPC, attackers can execute arbitrary PHP code via an XML file, which is not properly sanitized before being used in an eval statement.

Solution

Update the WordPress to the latest available version (at least 1.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.