WordPress ProductX – Gutenberg WooCommerce Blocks Plugin <= 3.1.4 is vulnerable to PHP Object Injection

Patch priority: high
Resolve immediately High priority
Not known to be exploited Report an attack
8.7
High severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Enable Protection

Solution

Fixed Update to fix
vPatch available vPatch available

Update the WordPress ProductX – Gutenberg WooCommerce Blocks plugin to the latest available version (at least 3.1.5).

Found this useful? Thank Yudistira Arya for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Published by Patchstack

Yudistira Arya discovered and reported this PHP Object Injection vulnerability in WordPress ProductX – Gutenberg WooCommerce Blocks Plugin. This could allow a malicious actor to execute code injection, SQL injection, path traversal, denial of service, and more if a proper POP chain is present. This vulnerability has been fixed in version 3.1.5.

This vulnerability was reported to and published by Patchstack. Our users receive alerts and protections up to 48 hours in advance.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
2 fixed
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Bug Bounty to earn bounties and rewards!

Learn more
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu