WordPress Event Manager for WooCommerce Plugin <= 4.1.1 is vulnerable to PHP Object Injection

Patch priority: medium
Resolve by 07 February, 2024 Medium priority
Not known to be exploited Report an attack
8.2
High severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Enable Protection

Solution

Fixed Update to fix
vPatch available vPatch available

Update the WordPress Event Manager for WooCommerce plugin to the latest available version (at least 4.1.2).

Found this useful? Thank Ngô Thiên An (ancorn_ from VNPT-VCI) for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Published by Patchstack

Ngô Thiên An (ancorn_ from VNPT-VCI) discovered and reported this PHP Object Injection vulnerability in WordPress Event Manager for WooCommerce Plugin. This could allow a malicious actor to execute code injection, SQL injection, path traversal, denial of service, and more if a proper POP chain is present. This vulnerability has been fixed in version 4.1.2.

This vulnerability was reported to and published by Patchstack. Our users receive alerts and protections up to 48 hours in advance.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
8 fixed
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Bug Bounty to earn bounties and rewards!

Learn more
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu