WordPress GetPaid plugin <= 2.3.3 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

invoicing

Software
GetPaid
Versions
<= 2.3.3
Disclosure date
2021-06-02
CVE
CVE-2021-24369
References
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

5.4

Medium

Requires contributor or higher user role.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Jörg Steinsträter in WordPress GetPaid plugin (versions <= 2.3.3).

Solution

Update the WordPress GetPaid plugin to the latest available version (at least 2.3.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.