Security programs Bounty leaderboard API Protect

WordPress Easy WP SMTP Plugin <= 1.5.1 is vulnerable to Arbitrary File Deletion

Patch immediately High priority
Not known to be exploited Report an attack
High severity CVSS 3.1 score

Protect your sites with automated security

Enable Protection



Update the WordPress Easy WP SMTP plugin to the latest available version (at least 1.5.2).


Show technical details

TomS discovered and reported this Arbitrary File Deletion vulnerability in WordPress Easy WP SMTP Plugin. This could allow a malicious actor to delete files from your website. If core files are deleted from your website, it could cause your site to break and stop functioning. This vulnerability has been fixed in version 1.5.2.

Other vulnerabilities in this plugin

0 present
6 patched
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close