WordPress Church Admin Plugin <= 3.7.29 is vulnerable to Cross Site Scripting (XSS)

Patch priority: medium
Resolve by 20 June, 2023 Medium priority
High severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Protect now

Patchstack is the official security point of contact for WordPress Church Admin plugin.


Fixed Update to fix
vPatch available vPatch available

Update the WordPress Church Admin plugin to the latest available version (at least 3.7.30).


Show technical details
Published by Patchstack

Phd discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress Church Admin Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 3.7.30.

This vulnerability was reported to and published by Patchstack. Our users receive alerts and protections up to 48 hours in advance.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
16 fixed
View all
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu