WordPress Royal Elementor Addons Plugin <= 1.7.1068 is vulnerable to Broken Access Control

Low priority No impactful threat
<= 1.7.1068Vulnerable version(s)
1.7.1069Patched version
6 Nov, 2026 by Patchstack

Get the fastest vulnerability mitigation with Patchstack!

Get started

Risks

CVSS 4.3

As immediate action, update the affected plugin. If you're unable to do so, ask your hosting provider or web developer for help.

4.3

Broken Access Control

Users can access pages or perform actions they shouldn't be allowed to, like viewing other people's data.

CVSS score is a way to evaluate and rank reported vulnerabilities in a standardized and repeatable way but which is not ideal for WordPress.

Solutions

This security issue has a low severity impact and is unlikely to be exploited.

Update to version 1.7.1069 or later.

Update to version 1.7.1069 or later to resolve the vulnerability.

Details

Have additional information or questions about this entry? Let us know.

Timeline

Reported byProfile ImageIhsan Saddan

25 Oct, 2026

Early warning sent out to Patchstack customers

6 Nov, 2026

Published by Patchstack

6 Nov, 2026

Weekly WordPress security intelligence delivered to your inbox.