WordPress Essential Addons for Elementor Plugin <= 6.8.7 is vulnerable to Privilege Escalation

Low priority No impactful threat
<= 6.8.7Vulnerable version(s)
6.8.8Patched version

Get the fastest vulnerability mitigation with Patchstack!

Get started

Risks

CVSS 7.4

As immediate action, update the affected plugin. If you're unable to do so, ask your hosting provider or web developer for help.

Note by Patchstack

Due to the nature of the vulnerability, a mitigation rule is not possible. However, it is unlikely to be mass-exploited due to the pre-requisites.

7.4

Privilege Escalation

A low-privilege user can become an admin and gain full control.

CVSS score is a way to evaluate and rank reported vulnerabilities in a standardized and repeatable way but which is not ideal for WordPress.

Solutions

This security issue has a low severity impact and is unlikely to be exploited.

Update to version 6.8.8 or later.

Update to version 6.8.8 or later to resolve the vulnerability.

Details

Have additional information or questions about this entry? Let us know.

Timeline

Published by Patchstack

30 Oct, 2026

Weekly WordPress security intelligence delivered to your inbox.