WordPress YOP Poll plugin <= 6.3.0 - Stored Cross-Site Scripting (XSS) vulnerability via Options Module

yop-poll

Software
YOP Poll
Vulnerable Versions
<= 6.3.0
Fixed in version
6.3.1
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-10-15
CVSS 3.0 score

6.9

Medium

Requires author or higher user role.

Are your websites subject to this vulnerability?

Details

Stored Cross-Site Scripting (XSS) vulnerability via Options Module discovered by Vishnupriya Ilango in WordPress YOP Poll plugin (versions <= 6.3.0).

Solution

Update the WordPress YOP Poll plugin to the latest available version (at least 6.3.1).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.