WordPress WPSchoolPress plugin <= 2.1.9 - Multiple Authenticated SQL Injections (SQLi) vulnerabilities

wpschoolpress

Software
WPSchoolPress
Vulnerable Versions
<= 2.1.9
Fixed in version
2.1.10
CVE
CVE-2021-24575
Credits
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2021-10-11
CVSS 3.0 score

8.8

High

Possible with low privilege user role like subscriber, or custom low privilege users like students.

Are your websites subject to this vulnerability?

Details

Multiple Authenticated SQL Injections (SQLi) vulnerabilities discovered by JrXnm in WordPress WPSchoolPress plugin (versions <= 2.1.9).

Solution

Update the WordPress WPSchoolPress plugin to the latest available version (at least 2.1.10).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.