WordPress WPSchoolPress plugin <= 2.1.16 - Multiple Stored Cross-Site Scripting (XSS) vulnerabilities

wpschoolpress

Software
WPSchoolPress
Vulnerable Versions
<= 2.1.16
Fixed in version
2.1.17
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-10-11
CVSS 3.0 score

6.9

Medium

Requires high privilege user authentication like admin.

Are your websites subject to this vulnerability?

Details

Multiple Stored Cross-Site Scripting (XSS) vulnerabilities were discovered by Davide Taraschi in the WordPress WPSchoolPress plugin (versions <= 2.1.16).

Solution

Update the WordPress WPSchoolPress plugin to the latest available version (at least 2.1.17).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.