API Monitor free
arrow right To plugin page
Verified
Fixed

WordPress WPide plugin <= 2.6 - Authenticated Arbitrary File Edit/Upload vulnerability

6.5
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Type
Plugin
Vulnerable versions
<= 2.6
Fixed in
3.0
PSID
6ecb43251ea1
Classification
Arbitrary File Upload
OWASP Top 10
A1: Injection
Required privilege
Requires high role user authentication like admin.
Publicly disclosed
2022-08-09

Details

Authenticated Arbitrary File Edit/Upload vulnerability discovered by Vlad Vector (Patchstack) in WordPress WPide plugin (versions <= 2.6).

Solution

Update the WordPress WPIDE – File Manager & Code Editor plugin to the latest available version (at least 3.0).

References

Other known vulnerabilities for WPIDE – File Manager & Code Editor

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close