WordPress WPFront User Role Editor plugin <= 3.1.0.10272 - Reflected Cross-Site Scripting (XSS) vulnerability

wpfront-user-role-editor

Software
WPFront User Role Editor
Vulnerable Versions
<= 3.1.0.10272
Fixed in version
3.2.1.11184
CVE
CVE-2021-24984
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-11-23
CVSS 3.0 score

4.1

Medium

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by JrXnm in WordPress WPFront User Role Editor plugin (versions <= 3.1.0.10272).

Solution

Update the WordPress WPFront User Role Editor plugin to the latest available version (at least 3.2.1.11184).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.