WordPress wpDataTables plugin <= 3.4.1 - Multiple SQL Injection (SQLi) vulnerabilities

wpdatatables

Software
wpDataTables
Versions
<= 3.4.1
Disclosure date
2021-03-16
CVE
CVE-2021-24199
Credits
Classification
SQL Injection
OWASP Top 10
A1: Injection
CVSS 3.0 score

8.1

High

User must be authenticated.

Are your websites subject to this vulnerability?

Details

Multiple SQL Injection (SQLi) vulnerabilities discovered by Veno Eivazian and Massimiliano Ferraresi in the WordPress wpDataTables plugin (versions <= 3.4.1).

Solution

Update the WordPress wpDataTables plugin to the latest available version (at least 3.4.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.