WordPress WP Upload Restriction plugin <= 2.2.3 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

wp-upload-restriction

Software
WP Upload Restriction
Vulnerable Versions
<= 2.2.3
Fixed in version
CVE
CVE-CVE-2021-34625
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-07-07
CVSS 3.0 score

6.4

Medium

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Angelo Righi in WordPress WP Upload Restriction plugin (versions <= 2.2.3).

Solution

This plugin has been closed as of July 1, 2021 and is not available for download. This closure is temporary, pending a full review.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.