WordPress WP SVG images plugin <= 3.3 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability via uploaded SVG file

wp-svg-images

Software
WP SVG images
Vulnerable Versions
<= 3.3
Fixed in version
3.4
CVE
CVE-2021-24386
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-06-14
CVSS 3.0 score

7.6

High

Requires user with file upload capability, author or higher level user authentication.

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability via uploaded SVG file discovered by Rasi in WordPress WP SVG images plugin (versions <= 3.3).

Solution

Update the WordPress WP SVG images plugin to the latest available version (at least 3.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.