WordPress WP Visitor Statistics (Real Time Traffic) plugin <= 4.7 - SQL Injection (SQLi) vulnerability

wp-stats-manager

Software
WP Visitor Statistics (Real Time Traffic)
Vulnerable Versions
<= 4.7
Fixed in version
4.8
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2021-11-22
CVSS 3.0 score

6.3

Medium

Requires subscriber or higher role user authentication.

Are your websites subject to this vulnerability?

Details

SQL Injection (SQLi) vulnerability discovered by Krzysztof Zając in WordPress WP Visitor Statistics (Real Time Traffic) plugin (versions <= 4.7).

Solution

Update the WordPress WP Visitor Statistics (Real Time Traffic) plugin to the latest available version (at least 4.8).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.