WordPress WP Hardening plugin <= 1.2.1 - Reflected Cross-Site Scripting (XSS) vulnerability

wp-security-hardening

Software
WP Hardening
Vulnerable Versions
<= 1.2.1
Fixed in version
1.2.2
CVE
CVE-2021-24373
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-06-07
CVSS 3.0 score

4.7

Medium

Are your websites subject to this vulnerability?

Details

Reflected Cross-Site Scripting (XSS) vulnerability discovered by dc11 in WordPress WP Hardening plugin (versions <= 1.2.1).

Solution

Update the WordPress WP Hardening plugin to the latest available version (at least 1.2.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.