Security programs Bounty leaderboard API Protect

WordPress WP Report Post Plugin <= 2.1.2 is vulnerable to Cross Site Request Forgery (CSRF)

Patch within 30 days Low priority
Not known to be exploited Report an attack
5.4
Medium severity CVSS 3.1 score

Protect your sites with automated security

Enable Protection

Solution

No fix

No patched version is available. The WordPress plugins review team was notified on 2023 April 20.

Found this useful? Thank Mika for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Verified

Mika discovered and reported this Cross Site Request Forgery (CSRF) vulnerability in WordPress WP Report Post Plugin. This could allow a malicious actor to force higher privileged users to execute unwanted actions under their current authentication. This vulnerability has not been known to be fixed yet.

Other vulnerabilities in this plugin

2 present
0 patched
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Alliance bounty platform and earn monthly cash prizes.

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close