WordPress wp-mpdf plugin <= 3.5.1 - Cross-Site Request Forgery (CSRF) vulnerability

wp-mpdf

Software
wp-mpdf
Vulnerable Versions
<= 3.5.1
Fixed in version
3.5.2
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-06-21
CVSS 3.0 score

4.7

Medium

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability discovered by Jerome Bruandet (NinTechNet) in WordPress wp-mpdf plugin (versions <= 3.5.1).

Solution

Update the WordPress wp-mpdf plugin to the latest available version (at least 3.5.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.