WordPress JobSearch premium plugin <= 1.8.1 - Authenticated Arbitrary WordPress Options Change vulnerability

wp-jobsearch

Software
JobSearch
Vulnerable Versions
<= 1.8.1
Fixed in version
1.8.2
Classification
Other Vulnerability Type
OWASP Top 10
A5: Broken Access Control
Disclosure Date
2021-10-05
CVSS 3.0 score

8.8

High

Requires custom plugin role like candidate or employer (low privileges).

Are your websites subject to this vulnerability?

Details

Authenticated Arbitrary WordPress Options Change vulnerability discovered by Jerome Bruandet (NinTechNet) in WordPress JobSearch premium plugin (versions <= 1.8.1).

Solution

Update the WordPress JobSearch premium plugin to the latest available version (at least 1.8.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.