WordPress WP HTML Mail Plugin <= 3.0.9 is vulnerable to Cross Site Scripting (XSS)

Patch priority: high
Resolve immediately High priority
Known to be exploited Active attempts logged
8.2
High severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Enable Protection

Solution

Fixed Update to fix
vPatch available vPatch available

Update the WordPress WP HTML Mail plugin to the latest available version (at least 3.1).

Chloe Chamberland (Wordfence) discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress WP HTML Mail Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 3.1.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
3 fixed
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Bug Bounty to earn bounties and rewards!

Learn more
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu