WordPress WP Hotel Booking plugin <= 1.10.2 - Unauthenticated Remote Code Execution (RCE) via Arbitrary Object Deserialisation vulnerability

wp-hotel-booking

Software
WP Hotel Booking
Versions
<= 1.10.2
Disclosure date
2021-03-03
Classification
PHP Object Injection
OWASP Top 10
A1: Injection

Are your websites subject to this vulnerability?

Details

Unauthenticated Remote Code Execution (RCE) via Arbitrary Object Deserialisation vulnerability discovered by Nick Blundell (AppCheck Ltd) in WordPress WP Hotel Booking plugin (versions <= 1.10.2).

Solution

Update the WordPress WP Hotel Booking plugin to the latest available version (at least 1.10.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.