WordPress WP Google Maps Pro premium plugin <= 8.1.11 - Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities

wp-google-maps-pro

Software
WP Google Maps Pro
Vulnerable Versions
<= 8.1.11
Fixed in version
8.1.12
CVE
CVE-2021-36871
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-06-15
CVSS 3.0 score

5.5

Medium

Requires high privilege user authentication like admin.

Are your websites subject to this vulnerability?

Details

Multiple Authenticated Persistent Cross-Site Scripting (XSS) vulnerabilities discovered by Vlad Visse (Patchstack Red Team) in WordPress WP Google Maps Pro premium plugin (versions <= 8.1.11). Vulnerable parameters: &wpgmaps_marker_category_name, Value > &attributes[], Name > &attributes[], &icons[], &names[], &description, &link, &title.

Solution

Update the WordPress WP Google Maps Pro premium plugin to the latest available version (at least 8.1.12).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.