WordPress WP Fastest Cache plugin <= 0.9.1.6 - Authenticated Arbitrary File Deletion via Path Traversal vulnerability

wp-fastest-cache

Software
WP Fastest Cache
Versions
<= 0.9.1.6
Disclosure date
2021-04-27
CVE
CVE-2021-20714
Credits
Classification
Directory Traversal
OWASP Top 10
A5: Broken Access Control
CVSS 3.0 score

3.8

Low

Are your websites subject to this vulnerability?

Details

Authenticated Arbitrary File Deletion via Path Traversal vulnerability discovered by Gen Sato in WordPress WP Fastest Cache plugin (versions <= 0.9.1.6).

Solution

Update the WordPress WP Fastest Cache plugin to the latest available version (at least 0.9.1.7).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.