Database Backup for WordPress plugin <= 2.3.3 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability

wp-db-backup

Software
Database Backup for WordPress
Versions
<= 2.3.3
Disclosure date
2021-04-22
CVE
CVE-N/A
References
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
CVSS 3.0 score

6.9

Medium

Are your websites subject to this vulnerability?

Details

Authenticated Persistent Cross-Site Scripting (XSS) vulnerability discovered by m0ze (Patchstack Red Team) in Database Backup for WordPress plugin (versions <= 2.3.3).

Solution

Update the Database Backup for WordPress plugin to the latest available version (at least 2.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.