WordPress WP-Cumulus Plugin 1.x - Cross-Site Scripting Vulnerability

wp-cumulus

Software
WP Cumulus
Versions
<= 1.22
Disclosure date
2009-11-09
CVE
CVE-2009-4168
References
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

WP-Cumulus plugin for WordPress is prone to a cross-site scripting vulnerability. It is caused by the application fails to properly clean up user-supplied input. An attacker may execute arbitrary script code in the browser of an user in the context of the affected site. In this way the attacker could steal cookie-based authentication credentials, also, implement other attacks.

Solution

Update the plugin.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.