WordPress WP Bannerize plugin 2.0.0 – 4.0.2 - Authenticated SQL Injection (SQLi) vulnerability

wp-bannerize

Software
WP Bannerize
Vulnerable Versions
2.0.0-4.0.2
Fixed in version
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2021-10-05
CVSS 3.0 score

7.7

High

Can be exploited by low privilege user.

Plugin does not exist, is not supported or discontinued.

Are your websites subject to this vulnerability?

Details

Authenticated SQL Injection (SQLi) vulnerability discovered by Margaux Dabert (Intrinsec) in WordPress WP Bannerize plugin (versions <= 2.0.0 – 4.0.2).

Solution

Deactivate and delete. This plugin has been closed as of July 19, 2021 and is not available for download. Reason: Security Issue.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.