WordPress core <= 5.8 - Data Exposure via REST API vulnerability

wordpress

Software
WordPress
Vulnerable Versions
<= 5.8
Fixed in version
5.8.1
Classification
Information Disclosure
OWASP Top 10
A6: Sensitive Data Exposure
Disclosure Date
2021-09-09
CVSS 3.0 score

5.3

Medium

Are your websites subject to this vulnerability?

Details

Data Exposure via REST API vulnerability discovered by Michael Adams in WordPress core (versions <= 5.8). Version update list: 5.8 updated to 5.8.1, 5.7.2 updated to 5.7.3, 5.7.1 updated to 5.7.3, 5.7 updated to 5.7.3, 5.6.4 updated to 5.6.5, 5.6.3 updated to 5.6.5, 5.6.2 updated to 5.6.5, 5.6.1 updated to 5.6.5, 5.6 updated to 5.6.5, 5.5.5 updated to 5.5.6, 5.5.4 updated to 5.5.6, 5.5.3 updated to 5.5.6, 5.5.2 updated to 5.5.6, 5.5.1 updated to 5.5.6, 5.5 updated to 5.5.6, 5.4.6 updated to 5.4.7, 5.4.5 updated to 5.4.7, 5.4.4 updated to 5.4.7, 5.4.3 updated to 5.4.7, 5.4.2 updated to 5.4.7, 5.4.1 updated to 5.4.7, 5.4 updated to 5.4.7

Solution

Update the WordPress core to the latest available version (at least 5.8.1).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.