WordPress <= 2.1.1 - Multiple Vulnerabilities

wordpress

Software
WordPress
Versions
<= 2.1.1
Disclosure date
2007-03-05
CVE
CVE-2007-1277
References
Credits
Classification
Multiple Vulnerabilities
OWASP Top 10

Are your websites subject to this vulnerability?

Details

The attackers can execute arbitrary commands via an eval injection vulnerability in the "ix" parameter to wp-includes/feed.php. Also, there is command execution backdoor vulnerability.

Solution

Update the WordPress to the latest available version (at least 2.1.2).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.