WordPress <= 1.5.1.2 - Multiple XSS vulnerabilities

wordpress

Software
WordPress
Versions
<= 1.5.1.2
Disclosure date
2005-07-01
CVE
CVE-2005-2107
References
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Because of these vulnerabilities in post.php, attackers can inject arbitrary web script or HTML via the "p" or "comment" parameter.

Solution

Update the WordPress to the latest available version (at least 1.5.1.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.