WordPress <= 1.2 - Remote Code Execution

wordpress

Software
WordPress
Versions
<= 1.2
Disclosure date
2005-10-27
CVE
CVE-2005-3330
References
Credits
Classification
Arbitrary Code Execution
OWASP Top 10

Are your websites subject to this vulnerability?

Details

Because of this vulnerability in The _httpsrequest function in Snoopy, the attackers can execute arbitrary commands via shell metacharacters in an HTTPS URL to an SSL protected web page, that is not properly handled by the fetch function.

Solution

Update the WordPress to the latest available version (at least 1.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.