WordPress Popular Posts plugin <= 5.3.3 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability

wordpress-popular-posts

Software
WordPress Popular Posts
Vulnerable Versions
<= 5.3.3
Fixed in version
5.3.4
CVE
CVE-2021-36872
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Disclosure Date
2021-07-04
CVSS 3.0 score

5.5

Medium

Requires high privilege user authentication like admin.

Are your websites subject to this vulnerability?

Details

Authenticated Persistent Cross-Site Scripting (XSS) vulnerability discovered by Vlad Visse (Patchstack) in WordPress Popular Posts plugin (versions <= 5.3.3).

Solution

Update the WordPress Popular Posts plugin to the latest available version (at least 5.3.4).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.