WordPress Popular Posts plugin <= 5.3.2 - Authenticated Code Injection vulnerability leading to Remote Code Execution (RCE)

wordpress-popular-posts

Software
WordPress Popular Posts
Vulnerable Versions
<= 5.3.2
Fixed in version
5.3.3
Classification
Remote Code Execution (RCE)
OWASP Top 10
A1: Injection
Disclosure Date
2021-06-11
CVSS 3.0 score

8.8

High

Requires contributor or higher user role.

Are your websites subject to this vulnerability?

Details

Authenticated Code Injection vulnerability leading to Remote Code Execution (RCE) discovered by NinTechNet in WordPress Popular Posts plugin (versions <= 5.3.2).

Solution

Update the WordPress Popular Posts plugin to the latest available version (at least 5.3.3).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.