WordPress WooCommerce plugin <= 5.1.0 - Authenticated Persistent Cross-Site Scripting (XSS) vulnerability

woocommerce

Software
WooCommerce
Versions
<= 5.1.0
Disclosure date
2021-04-29
CVE
CVE-N/A
References
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)
CVSS 3.0 score

5.4

Medium

Are your websites subject to this vulnerability?

Details

Authenticated Persistent Cross-Site Scripting (XSS) vulnerability discovered by m0ze in WordPress WooCommerce plugin (versions <= 5.1.0).

Solution

Update the WordPress WooCommerce plugin to the latest available version (at least 5.2.0).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.