WordPress WooCommerce plugin <= 3.4.4 - Potential Object Injection vulnerability

woocommerce

Software
WooCommerce
Versions
<= 3.4.4
Disclosure date
2018-09-01
CVE
CVE-N/A
References
Credits
Classification
Other Vulnerability Type
OWASP Top 10
A1: Injection

Are your websites subject to this vulnerability?

Details

According to WooCommerce, versions, 3.4.4 and earlier are affected by an issue where a function that updates attributes could lead to object injection, related to the WordPress 4.8.3 security release.

Solution

Update the WordPress WooCommerce plugin to the latest available version (at least 3.4.5).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.