WordPress WooCommerce Stock Manager plugin <= 2.5.7 - Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary File Upload

woocommerce-stock-manager

Software
WooCommerce Stock Manager
Vulnerable Versions
<= 2.5.7
Fixed in version
2.6.0
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-06-14
CVSS 3.0 score

8.8

High

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Arbitrary File Upload discovered by Chloe Chamberland (WordFence) in WordPress WooCommerce Stock Manager plugin (versions <= 2.5.7).

Solution

Update the WordPress WooCommerce Stock Manager plugin to the latest available version (at least 2.6.0).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.