WordPress WooCommerce Multi Currency - Currency Switcher premium plugin <= 2.1.17 - Authenticated Product Price Change vulnerability

woocommerce-multi-currency

Software
WooCommerce Multi Currency - Currency Switcher
Vulnerable Versions
<= 2.1.17
Fixed in version
2.1.18
Classification
Broken Authentication
OWASP Top 10
A7: Missing Function Level Access Control
Disclosure Date
2021-09-13
CVSS 3.0 score

6.5

Medium

Can be exploited with customer role user.

Are your websites subject to this vulnerability?

Details

Authenticated Product Price Change vulnerability discovered by Jerome Bruandet (NinTechNet) in WordPress WooCommerce Multi Currency - Currency Switcher premium plugin (versions <= 2.1.17).

Solution

Update the WordPress WooCommerce Multi Currency - Currency Switcher premium plugin to the latest available version (at least 2.1.18).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.