WordPress Live Product Editor for WooCommerce plugin <= 4.6.1 - Multiple vulnerabilities

woocommerce-frontend-shop-manager

Software
Live Product Editor for WooCommerce
Vulnerable Versions
<= 4.6.1
Fixed in version
4.7.0
Classification
Multiple Vulnerabilities
OWASP Top 10
A1: Injection
Disclosure Date
2021-09-20
CVSS 3.0 score

8.8

High

Possible with customer (WooCommerce) role user.

Are your websites subject to this vulnerability?

Details

Multiple vulnerabilities (Authenticated Arbitrary WordPress Options Change, Read and Deletion / Authenticated User Enumeration / Authenticated Plugin Settings Change, Import and Export) were discovered by Jerome Bruandet (NinTechNet) in WordPress Live Product Editor for WooCommerce plugin (versions <= 4.6.1).

Solution

Update the WordPress Live Product Editor for WooCommerce plugin to the latest available version (at least 4.7.0).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.