WordPress WCFM Marketplace plugin <= 3.4.11 - Unauthenticated SQL Injection (SQLi) vulnerability

wc-multivendor-marketplace

Software
WCFM Marketplace
Vulnerable Versions
<= 3.4.11
Fixed in version
3.4.12
CVE
CVE-2021-24849
Credits
Classification
SQL Injection
OWASP Top 10
A1: Injection
Disclosure Date
2021-11-22
CVSS 3.0 score

7.3

High

Can be exploited remotely without any authentication.

Are your websites subject to this vulnerability?

Details

Unauthenticated SQL Injection (SQLi) vulnerability discovered by JrXnm in WordPress WCFM Marketplace plugin (versions <= 3.4.11).

Solution

Update the WordPress WCFM Marketplace plugin to the latest available version (at least 3.4.12).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.