API Monitor free
arrow right To plugin page
Fixed

WordPress WP Sticky Button plugin <= 1.4.0 - Unauthenticated Arbitrary Settings Update vulnerability leading to Stored Cross-Site Scripting (XSS)

6.1
CVSS 3.1 score Medium severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Type
Plugin
Vulnerable versions
<= 1.4.0
Fixed in
1.4.1
PSID
8e91b06ffa00
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Can be exploited remotely without any authentication.
Publicly disclosed
2022-08-01

Details

Unauthenticated Arbitrary Settings Update vulnerability leading to Stored Cross-Site Scripting (XSS) discovered by Krzysztof Zając in WordPress WP Sticky Button plugin (versions <= 1.4.0).

Solution

Update the WordPress WP Sticky Button – Click to Chat plugin to the latest available version (at least 1.4.1).

References

Vulnerability details

No other known vulnerabilities found for WP Sticky Button – Click to Chat.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close