WordPress W4 Post List Plugin <= 2.4.4 is vulnerable to Cross Site Scripting (XSS)

Patch priority: low
Resolve by 07 April, 2023 Low priority
6.5
Medium severity CVSS 3.1 score

Prevent exploits against this and future vulnerabilities!

Protect now

Solution

Fixed Update to fix

Update the WordPress W4 Post List plugin to the latest available version (at least 2.4.5).

Found this useful? Thank Abdi Pranata for reporting this vulnerability. Buy a coffee ☕

Details

Show technical details
Published by Patchstack

Abdi Pranata discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress W4 Post List Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 2.4.5.

This vulnerability was reported to and published by Patchstack. Our users receive alerts and protections up to 48 hours in advance.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
4 fixed
View all
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu