WordPress VikRentCar plugin <= 1.1.6 - Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS)

vikrentcar

Software
VikRentCar
Vulnerable Versions
<= 1.1.6
Fixed in version
1.1.7
CVE
CVE-2021-24388
Credits
Classification
Cross Site Request Forgery (CSRF)
OWASP Top 10
A8: Cross Site Request Forgery (CSRF)
Disclosure Date
2021-06-14
CVSS 3.0 score

6.1

Medium

Are your websites subject to this vulnerability?

Details

Cross-Site Request Forgery (CSRF) vulnerability leading to Stored Cross-Site Scripting (XSS) discovered by Satyender Yadav in WordPress VikRentCar plugin (versions <= 1.1.6).

Solution

Update the WordPress VikRentCar plugin to the latest available version (at least 1.1.7).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.