Update the WordPress Welcart e-Commerce plugin to the latest available version (at least 2.8.4).
Lana Codes discovered and reported this Cross Site Scripting (XSS) vulnerability in WordPress Welcart e-Commerce Plugin. This could allow a malicious actor to inject malicious scripts, such as redirects, advertisements, and other HTML payloads into your website which will be executed when guests visit your site. This vulnerability has been fixed in version 2.8.4.
Commerce plugin <= 2.8.3 Auth. Arbitrary Shipping Method Creation/Update/Deletion vulnerability
Unauth. Directory Traversal vulnerability
Commerce plugin <= 2.2.7 Unauthenticated Information Disclosure vulnerability
Commerce plugin <= 2.2.7 Authenticated System Information Disclosure vulnerability
Commerce plugin <= 2.2.3 CrossSite Scripting (XSS) vulnerability