WordPress Welcart e-Commerce Plugin <= 2.7.7 is vulnerable to Directory Traversal

Patch priority: high
Resolve immediately High priority
Not known to be exploited Report an attack
7.5
High severity CVSS 3.1 score

Detect and mitigate security vulnerabilities at scale with Patchstack!

Enable Protection

Solution

Fixed Update to fix
vPatch available vPatch available

Update the WordPress Welcart e-Commerce plugin to the latest available version (at least 2.7.8).

Found this useful? Thank Nguyen Anh Tien for reporting this vulnerability. Buy a coffee ☕

Nguyen Anh Tien discovered and reported this Directory Traversal vulnerability in WordPress Welcart e-Commerce Plugin. This could allow a malicious actor to see all files in a given directory or determine if certain files/directories exist in given folder. This can be used to exploit other weaknesses in the system This vulnerability has been fixed in version 2.7.8.

Have additional information or questions about this entry? Get in touch.

Other vulnerabilities in this plugin

0 present
18 fixed
View all

WordPress plugin developer?

Start a free security program for your WordPress plugins or request an audit.

Apply for MVDP

Security researcher?

Report to Patchstack Bug Bounty to earn bounties and rewards!

Learn more
Mobile Menu

Let us know if we have missed a vulnerability reported elsewhere

Mobile Menu Close

Thank you for contributing!

Close Mobile Menu