API Monitor free
arrow right To plugin page
Fixed

WordPress Tripetto plugin <= 5.1.4 - Unauthenticated Cross-Site Scripting (XSS) vulnerability via SVG image upload

4.7
CVSS 3.1 score Medium severity
Monitoring Coming soon

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Type
Plugin
Vulnerable versions
<= 5.1.4
Fixed in
5.2.0
PSID
be0c01109168
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Can be exploited remotely without any authentication.
Publicly disclosed
2022-04-26

Details

Unauthenticated Cross-Site Scripting (XSS) vulnerability via SVG image upload discovered by Ngo Van Thien (Patchstack Alliance) in WordPress Tripetto plugin (versions <= 5.1.4).

Solution

Update the WordPress Tripetto plugin to the latest available version (at least 5.2.0).

References

CVE-2021-36895 Plugin changelog

Other known vulnerabilities for WordPress form builder plugin for contact forms, surveys and quizzes – Tripetto

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close