API Monitor free
arrow right To plugin page
Fixed

WordPress Top Bar plugin <= 3.0.3 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

4.8
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Top Bar
Type
Plugin
Vulnerable versions
<= 3.0.3
Fixed in
3.0.4
PSID
8d6e4824ba1f
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires high role user authentication like admin.
Publicly disclosed
2022-09-19

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability discovered by Asif Nawaz Minhas in WordPress Top Bar plugin (versions <= 3.0.3).

Solution

Update the WordPress Top Bar plugin to the latest available version (at least 3.0.4).

References

Vulnerability details

No other known vulnerabilities found for Top Bar.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close