API Monitor free
arrow right To plugin page
Fixed

WordPress TaskBuilder plugin <= 1.0.7 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

5.4
CVSS 3.1 score Medium severity
Report
Monitoring Not reported to be exploited

Find out about vulnerable plugins in your websites for free.

Scan your website arrow right
Software
Taskbuilder
Type
Plugin
Vulnerable versions
<= 1.0.7
Fixed in
1.0.8
PSID
60e3cccfb3a6
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A7: Cross-Site Scripting (XSS)
Required privilege
Requires subscriber or higher role user authentication.
Publicly disclosed
2022-09-15

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability via SVG file upload discovered by Rizacan Tufan in WordPress TaskBuilder plugin (versions <= 1.0.7).

Solution

Update the WordPress Taskbuilder plugin to the latest available version (at least 1.0.8).

References

Vulnerability details

No other known vulnerabilities found for Taskbuilder.
Let us know if we missed something.

Report a vulnerability

Submit vulnerabilities and become a verified Alliance member

Learn more

Let us know if we have missed a vulnerability reported elsewhere

Report arrow right Close

Thank you for contributing!

Successfully submit vulnerabilities and receive an invite to our Alliance platform.

Learn more arrow right Close