WordPress Subscribe to Comments Plugin 2.0 - Multiple Cross-Site Scripting Vulnerabilities

subscribe-to-comments

Software
Subscribe to Comments
Versions
<= 2.0
Disclosure date
2009-11-16
CVE
CVE-N/A
References
Credits
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Subscribe to Comments plugin is prone to a cross-site scripting. Application fails to sufficiently clean up user-supplied data. The attacker-supplied could run HTML or JavaScript code in the context of the affected site. In that way the attacker can steal cookie-based authentication credits. There are other attacks also possible.

Solution

Upgrade the plugin.

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.