WordPress Stripe Payments plugin <= 2.0.39 - Authenticated Stored Cross-Site Scripting (XSS) vulnerability

stripe-payments

Software
Stripe Payments
Versions
<= 2.0.39
Disclosure date
2021-01-08
Classification
Cross Site Scripting (XSS)
OWASP Top 10
A3: Cross Site Scripting (XSS)

Are your websites subject to this vulnerability?

Details

Authenticated Stored Cross-Site Scripting (XSS) vulnerability found by Park Won Seok in WordPress Stripe Payments plugin (versions <= 2.0.39).

Solution

Update the WordPress Stripe Payments plugin to the latest available version (at least 2.0.40).

Found a vulnerability that puts your sites at risk?

Found a vulnerability? Help us secure the web and join our community of ethical hackers.

Are you the developer of this software? Hire our researchers for a thorough security audit.